Call Sheet Samples Issues

While many computers can now open PDF files natively, Adobe Reader 8.0 or greater is required in order to open and read the PDF Portfolios.